Итоговое тестирование по информатике 10 класс

Тест по информатике 10 класс
Вариант 1
1. ОЗУ (RAM) - это память, в которой:
а) хранится исполняемая в данный момент времени программа и данные, с которыми она не-
посредственно работает;
б) хранится информация, присутствие которой постоянно необходимо в компьютере;
в) хранится информация, независимо от того работает ЭВМ или нет;
г) хранятся программы, предназначенные для обеспечения диалога пользователя с ЭВМ.
2. Компьютер - это:
а) устройство для хранения и выдачи информации;
б) это устройство для обработки информации;
в) универсальное, электронное, программно-управляемое устройство для хранения, обра-
ботки и передачи информации;
г) универсальное устройство для передачи информации.
3. Что такое КЕШ-память
а) память, в которой обрабатывается одна программа в данный момент времени;
б) память, предназначенная для долговременного хранения информации, независимо от того
работает ЭВМ или нет;
в) это сверхоперативная память, в которой хранятся наиболее часто используемые участки
оперативной памяти;
г) память, в которой хранятся системные файлы операционной системы.
4. Какой объем в Кб занимает текст в памяти компьютера, если мощность алфавита, с
помощью которого он записан, равна 16 символов и количество символов в тексте
262144?
а) 128;
б) 131072;
в) 1024;
г) 1048576.
5. Перевести из десятичной системы счисления в двоичную 12,25
10
а) 11100,11
2
б) 1100,01
2
в) 10111,11
2
г) 11110,10
2
6. Перевести в десятичную систему счисления из восьмеричной - 177
8
а)127
10
б) 120
10
в) 177
10
г) 117
10
7. На что указывает расширение файлов?
а) на место хранение;
б) на вид архива;
в) на программу просмотра;
г) на объем файла.
8. Для какого типа переменных в Паскале допустимы операции mod и div?
а) real;
б) integer;
в) boolean;
г) char.
9. По особенностям алгоритма вирусы не делятся на:
а) мутанты;
б) троянские;
в) невидимки;
г) резидентные.
10. Запишите значение переменной s, полученное в результате работы следующей
программы.
алг
нач
цел s, k
s := 9
нц для k от 3 до 7
s := s + 9
кц
вывод s
кон
11. Произведите сложение с числами 0,1*2
5
и 0,1*2
3
12. Файл размером 16 Кбайт передаётся через некоторое соединение со скоростью 2048 бит в
секунду. Определите размер файла Кбайт), который можно передать за то же время через
другое соединение со скоростью 256 бит в секунду. В ответе укажите одно число размер
файла в Кбайт.
13. В таблице Tab хранятся данные о количестве сделанных учениками заданий (Tab[1]
заданий сделал первый ученик, Tab[2] второй и т.д.). Определите, какое число будет
напечатано в результате работы следующей программы.
алг
нач
целтаб Tab[1:10]
цел k, m
Tab[1] := 7; Tab[2] := 9
Tab[3] := 10; Tab[4] := 5
Tab[5] := 6; Tab[6] := 7
Tab[7] := 9; Tab[8] := 8
Tab[9] := 6; Tab[10] := 9
m := 0
нц для k от 1 до 10
если Tab[k] > 6 то
m := m + 1
все
кц
вывод m
кон.
Тест по информатике 10 класс
Вариант 2
1.Назначение процессора:
а) обрабатывать одну программу в данный момент времени;
б) управлять ходом вычислительного процесса и выполнять арифметические и логические
действия;
в) осуществлять подключение периферийных устройств к магистрали;
г) руководить работой вычислительной машины с помощью электрических импульсов.
2. Количество битов, воспринимаемое микропроцессором как единое целое – это:
а) разрядность процессора
б) тактовая частота
в) объем внутренней памяти компьютера
г) производительность компьютера
3. Разрядность процессора определяется:
а) количеством двоичных разрядов, которые процессор обрабатывает за один такт;
б) количеством двоичных разрядов, которые процессор обрабатывает за одну минуту;
в) разрядностью шины адреса;
г) нет правильного ответа.
4. Путь к файлу включает в себя:
а) корневой каталог;
б) имя файла без расширения;
в) имя файла с расширением;
г) расширение.
5. Перевести из десятичной системы счисления в восьмеричную - 502
10
а) 667
8
б) 76,6
8
в) 66,7
8
г) 766
8
6. Перевести в десятичную систему счисления из шестнадцатеричной 1E,5
16
а) 30,3125
10
б) 25,325
10
в) 30,125
10
г) 25,305
10
7. На полке стоят 256 видеокассет. Сколько информации несет сообщение о том, что
взяли одну из них?
а) 8 байт
б) 8 бит
в) 7 байт
г) 7 бит
8. В Паскале имя программы и переменной может начинаться:
а) с буквы;
б) с арабской цифры;
в) со скобки;
г) с латинской цифры
9. Антивирусные программы не делятся на:
а) доктора;
б) ревизоры;
в) вакцины;
г) патрули.
10. Запишите значение переменной s, полученное в результате работы следующей
программы.
алг
нач
цел s, k
s := 8
нц для k от 2 до 8
s := s + 8
кц
вывод s
кон
11. Произведите вычитание с числами 0,1*2
2
и 0,1*2
-2
12. Файл размером 16 Кбайт передаётся через некоторое соединение со скоростью 1024 бит в
секунду. Определите размер файла Кбайт), который можно передать за то же время через
другое соединение со скоростью 256 бит в секунду. В ответе укажите одно число размер
файла в Кбайт.
13. В таблице Tab хранятся данные о количестве сделанных учениками заданий (Tab[1]
заданий сделал первый ученик, Tab[2] второй и т.д.). Определите, какое число будет
напечатано в результате работы следующей программы.
алг
нач
целтаб Tab[1:10]
цел k, m
Tab[1] := 7; Tab[2] := 9
Tab[3] := 10; Tab[4] := 5
Tab[5] := 6; Tab[6] := 7
Tab[7] := 9; Tab[8] := 8
Tab[9] := 6; Tab[10] := 9
m := 0
нц для k от 1 до 10
если Tab[k] < 7 то
m := m + Tab[k]
все
кц
вывод m
кон
Тест по информатике 10 класс
На отметку «удовлетворительно» необходимо правильно выполнить 6 заданий, на
«хорошо» 10 заданий и «отлично» 12 и более заданий.
Вариант 3
1. Архитектура ЭВМ - это:
а) описание деталей технического и физического устройства компьютера;
б) описание набора устройств ввода-вывода;
в) описание программного обеспечения необходимого для работы ЭВМ;
г) описание структуры и функций ЭВМ на уровне, достаточном для понимания принципов
работы и системы команд ЭВМ.
2. Информационная магистраль - это:
а) набор команд, предназначенный для управления процессом обработки данных в ЭВМ;
б) кабель, осуществляющий информационную связь между устройствами компьютера;
в) количество одновременно передаваемых по шине бит;
г) быстрая, полупроводниковая, энергонезависимая память.
3. Разрядность шины данных определяется:
а) объемом адресуемой памяти;
б) пропускной способностью шины;
в) разрядностью процессора;
г) правильного ответа нет.
4. Многоуровневая файловая система отличается от одноуровневой:
а) наличием вложенных папок;
б) количеством вложенных папок;
в) наличием корневого каталога;
г) возможность указания пути к файлу.
5. Перевести из десятичной системы счисления в шестнадцатеричную 605
10
а) 2531
16
б) 1352
16
в) 25D
16
г) 37D
16
6. Перевести в десятичную систему счисления из двоичной 1101,101
2
а) 1101,101
10
б) 10,259
10
в) 13,625
10
г)12,725
10
7. На столе лежали конфеты. В сообщении о том, что взяли одну из них содержится 5
бита информации. Сколько конфет лежало на столе?
а) 10
б) 15
в) 32
г) 5
8. Для какого типа переменных в Паскале не допустима операция деления?
а) real;
б) integer;
в) boolean;
г) char.
9. По среде обитания вирусов, не бывает:
а) сетевые;
б) файловые;
в) загрузочные;
г) резидентные.
10. Запишите значение переменной s, полученное в результате работы следующей
программы.
алг
нач
цел s, k
s := 0
нц для k от 5 до 11
s := s + 6
кц
вывод s
кон
11. Произведите деление с числами 0,01*2
4
и 0,1*2
-2
12. Файл размером 4 Кбайт передаётся через некоторое соединение со скоростью 2048 бит в
секунду. Определите размер файла байтах), который можно передать за то же время через
другое соединение со скоростью 256 бит в секунду. В ответе укажите одно число размер
файла в байтах.
13. В таблице Tab хранятся данные о количестве учеников в классах (Tab[1]
количество учеников в первом классе, Tab[2] во втором и т. д.). Определите, какое
число будет напечатано в результате работы следующей программы.
алг
нач
целтаб Tab[1:11]
цел k, m
Tab[1] := 20; Tab[2] := 25
Tab[3] := 19; Tab[4] := 25
Tab[5] := 26; Tab[6] := 22
Tab[7] := 24; Tab[8] := 28
Tab[9] := 26; Tab[10] := 21
Tab[11] := 27
m := 0
нц для k от 1 до 11
если Tab[k] >= 25 то
m := m + 1
все
кц
вывод m
кон
Тест по информатике 10 класс
Вариант 4
1. Компьютер - это:
а) устройство для хранения и выдачи информации;
б) это устройство для обработки информации;
в) универсальное устройство для передачи информации;
г) универсальное, электронное, программно-управляемое устройство для хранения, обра-
ботки и передачи информации.
2. Какую функцию выполняют периферийные устройства?
а) хранение информации;
б) обработку информации
в) ввод и вывод информации;
г) управление работой ЭВМ по заданной программе.
3. В процессе обработки программа и данные должны быть загружены:
а) на жесткий диск;
б) в оперативную память;
в) в постоянную память;
г) в КЕШ память.
4. Текст занимает 1,5 Кбайта памяти компьютера. Сколько символов содержит этот
текст, если мощность алфавита равна 64?
а) 256
б) 2048
в) 1024
г) 1000
5. Перевести из десятичной системы счисления в двоичную 12,5
10
а) 1100,1
2
б) 1111,1
2
в) 10111,11
2
г) 1100,01
2
6. Перевести в десятичную систему счисления из восьмеричной 177
8
а) 271
10
б) 127
10
в) 165
10
г) 261
10
7. Какие имена файлов составлены, верно:
а) «пример».doc;
б) пример. doc;
в) doc?. Пример;
г)пример: doc;
8 В алфавит языка Паскаль не входит служебное слово:
а) STEP;
б) BEGIN;
в) THEN;
г) IF.
9. К антивирусным программам не относится:
а) сторожа;
б) фаги;
в) ревизоры;
г) интерпретаторы.
10. Запишите значение переменной s, полученное в результате работы следующей
программы.
алг
нач
цел s, k
s := 7
нц для k от 2 до 8
s := s + 7
кц
вывод s
кон
11. Произведите вычитание с числами 0,001*2
3
и 0,1*2
-2
12. Файл размером 32 Кбайт передаётся через некоторое соединение со скоростью 4096 бит в
секунду. Определите размер файла Кбайт), который можно передать за то же время через
другое соединение со скоростью 256 бит в секунду. В ответе укажите одно число размер
файла в Кбайт.
13. В таблице Tab хранятся данные о количестве сделанных учениками заданий (Tab[1]
заданий сделал первый ученик, Tab[2] второй и т. д.). Определите, какое число будет
напечатано в результате работы следующей программы.
алг
нач
целтаб Tab[1:10]
цел k, m, n
Tab[1] := 7; Tab[2] := 9
Tab[3] := 10; Tab[4] := 5
Tab[5] := 6; Tab[6] := 7
Tab[7] := 9; Tab[8] := 10
Tab[9] := 6; Tab[10] := 9
m := 0 ; n := 0
нц для k от 1 до 10
если Tab[k] >= m то
m := Tab[k]
n := k
все
кц
вывод n
кон