Контрольная работа "Алгоритмика" 6 класс


1
Контрольная работа №2
«Алгоритмика»
Вариант 1
1. Закончите определение.
Исполнитель – это …
2. Укажите примеры формальных исполнителей в предложенных ситуациях.
А). Симфонический оркестр исполняет музыкальное произведение.
Б). Ученик 7 класса решает задачи по алгебре.
В). Фармацевт готовит лекарство по рецепту.
Г). Врач устанавливает причину плохого самочувствия у больного.
Д). Автомат на конвейере наполняет бутылки лимонадом.
Е). Компьютер выполняет программу проверки правописания.
3. Запишите с помощью блок-схемы пословицу «Болен – лечись, а здоров – берегись».
4. Что получится в результате действий исполнителя Чертежник по следующему алгоритму?
использовать Чертежник
алг рисунок
нач
сместиться в точку (1, 1)
нц 3 раз
опустить перо
сместиться на вектор (1, 3)
сместиться на вектор (1, -3)
сместиться на вектор (-2, 0)
поднять перо
сместиться на вектор (3, 0)
кц
кон
2
Вариант 2
1. Закончите определение.
Алгоритм – это …
2. Укажите примеры неформальных исполнителей в предложенных ситуациях.
А). Симфонический оркестр исполняет музыкальное произведение.
Б). Ученик 7 класса решает задачи по алгебре.
В). Фармацевт готовит лекарство по рецепту.
Г). Врач устанавливает причину плохого самочувствия у больного.
Д). Автомат на конвейере наполняет бутылки лимонадом.
Е). Компьютер выполняет программу проверки правописания.
3. Запишите с помощью блок-схемы пословицу «Поспешишь – людей насмешишь».
4. Что получится в результате действий исполнителя Чертежник по следующему алгоритму?
использовать Чертежник
алг рисунок
нач
сместиться в точку (1, 1)
нц 4 раз
опустить перо
сместиться на вектор (1, 3)
сместиться на вектор (1, -3)
сместиться на вектор (-2, 0)
поднять перо
сместиться на вектор (3, 0)
кц
кон
3
Ответы
Вариант 1
1. Исполнитель — это некоторый объект (человек, животное, техническое устройство), способный
выполнять определенный набор команд.
2. В, Д, Е
3.
4.
НЕТ
ДА
Начало
Болен?
Лечись
Берегись
Конец
4
Вариант 2
1. Алгоритм — это предназначенное для конкретного исполнителя точное описание конечной
последовательности действий, направленных на решение поставленной задачи.
2. А, Б, Г
3.
4.
НЕТ
ДА
Начало
Поспешишь?
Людей насмешишь
Не насмешишь
Конец
5
задания
Макси-
мальный
балл
КЭС
Контролируемые элементы содержания
1
10
1.3.1
Алгоритм, свойства алгоритмов, способы записи алгоритмов. Блок-
схемы.
Дополнительно: Определения исполнителя, алгоритма
2
10
1.3.1
Алгоритм, свойства алгоритмов, способы записи алгоритмов. Блок-
схемы.
Дополнительно: Разнообразие исполнителей
3
10
1.3.1
Алгоритм, свойства алгоритмов, способы записи алгоритмов. Блок-
схемы.
Дополнительно: Способы записи алгоритма
4
10
1.3.1
Алгоритм, свойства алгоритмов, способы записи алгоритмов. Блок-
схемы.
Дополнительно: Исполнитель Чертёжник