Презентация "Разветвляющийся алгоритм" 9 класс


Подписи к слайдам:
Разветвляющийся алгоритм

Разветвляющийся алгоритм

Муниципальное общеобразовательное учреждение гимназия №1

Учитель информатики: Скабёлкина М.Ю.

Липецк 2011

6 класс

Цель урока:

  • организация работы по усвоению новых понятий, предусмотренных учебной программой, формирования знаний в области алгоритмов

Вопросы

  • Что такое алгоритм?
  • Назовите простые команды.
  • Что такое линейный алгоритм?

Задача

Известно, что один маляр покрасил А м2 , а другой

В м2 . Найти площадь покраски двух маляров – S.

алг площадь (цел A, B вещ S)

арг А, В

рез S

нач

ввод А, В

S:= А+ В

вывод S

кон

Алгоритмы, при исполнении которых порядок следования команд определяется в зависимости от результатов проверки некоторых условий, называют разветвляющимися.

Алгоритмический язык

Если <условие>

то <серия 1>

иначе <серия 2>

все

<Серия> - это одна или несколько следующих друг за другом команд

Полное ветвление

  • Если условие справедливо, то выполняется серия 1, в противном случае – серия 2.

условие

Серия 1

Серия 2

Неполное ветвление

Если <условие>

то <серия>

все

условие

серия

Даны два числа. Найти наибольшее из этих чисел

Алг мах

арг а, в

рез мах

нач

ввод а, в

если а>в

то мах:=а

иначе мах:=в

все

вывод мах

кон

нач

a,b

a>b

max:=a

max:=b

max

кон

Вычислить значение функции: y = √4x+3

алг «значение функции» (x – нат, вещ y)

арг x

рез y

нач ввод x

z := 4x +3

если z >=0

то y: = √z

вывод y

иначе вывод «решений нет»

все

кон

начало

z: = 4x+3

z >=0

-

+

Y: = √z

решений нет

конец

Практическая работа

  • Увеличить число x на 5, если оно положительное.
  • Даны действительные числа х и у, не равные друг другу. Меньшее из этих двух чисел увеличить на 4, а большее – в 4 раза.

Подведение итогов

  • Какие алгоритмы называют разветвляющимися?
  • С чего начинается команда ветвление?

Домашняя работа

1. Записи по тетради.

2. Решить задачу в тетради:

Даны два действительных числа х и y. Большее из этих чисел заменить их суммой, меньшее их произведением.

Разветвляющийся алгоритм

Муниципальное общеобразовательное учреждение гимназия №1

Учитель информатики: Скабёлкина М.Ю.

Липецк 2011

6 класс