Презентация "Цикл с предусловием «Пока»" 7 класс скачать бесплатно


Презентация "Цикл с предусловием «Пока»" 7 класс


Подписи к слайдам:
Слайд 1

Цикл с предусловием «Пока»

Муниципальное общеобразовательное учреждение гимназия №1

Учитель информатики: Скабёлкина М.Ю.

Липецк 2011

7 класс

Что такое линейный алгоритм?

  • Что такое линейный алгоритм?
  • Как записывается основной вид алгоритма на псевдокоде?
  • Какая форма организации действий называется ветвлением?
  • Как оформляются в алгоритмах ветвления?

Цикл форма организации действий, при которой одна и та же последовательность действий совершается несколько раз до тех пор, пока выполняется какое — либо условие.

Цикл форма организации действий, при которой одна и та же последовательность действий совершается несколько раз до тех пор, пока выполняется какое — либо условие.

Пока <условие>

Пока <условие>

нц

<тело цикла>

кц

Решение задач

Написать алгоритм, выводящий таблицу умножения на 3.

алг Таблица умножения на З

арг К

нач

К:=1

пока К<=10

нц

вывод 3*К

к:=к+1

кц

кон

Решение задач

Решение задач

В первый день тренировок спортсмен пробежал 10 км, каждый последующий день он увеличивал дневную норму на 10% от нормы предыдущего дня. Через сколько дней спортсмен будет пробегать в день более 20 км?

Решение задач

алг спортсмен

арг n нат; к вещ

нач

n:=1

к:=10

пока к<=20

нц

к:=к+к*0.1

n:=n+1

кц

вывод n

кон

Решение задач

Дано натуральное число, определить сумму цифр числа

алг Сумма цифр числа

арг n, s, с - нат

нач

ввод n

S:=0

пока n<>0

нц

с:=ост n/10

n:=n\10

s:=s+c

кц

вывод s

кон

Решение задач

1. Составьте таблицу умножения на 5.

1. Составьте таблицу умножения на 5.

2. Начав тренировки, спортсмен пробегает 10 км. Последующие дни он увеличивал свой пробег на 10%. Через, сколько дней суммарный путь спортсмена превысит 100 км.

Что нового узнали на сегодняшнем уроке?

  • Что нового узнали на сегодняшнем уроке?
  • Что повторили?
  • Что такое «циклический алгоритм»?

Василиса прекрасная сказала Кощею бессмертному, что выйдет за него замуж тогда, когда у него будет 5000 сундуков с золотом, сейчас у него 3000 сундуков, каждый год кол-во сундуков увеличивается на 20%. Через, сколько лет Василиса выйдет замуж?

Василиса прекрасная сказала Кощею бессмертному, что выйдет за него замуж тогда, когда у него будет 5000 сундуков с золотом, сейчас у него 3000 сундуков, каждый год кол-во сундуков увеличивается на 20%. Через, сколько лет Василиса выйдет замуж?

Цикл с предусловием «Пока»

Муниципальное общеобразовательное учреждение гимназия №1

Учитель информатики: Скабёлкина М.Ю.

Липецк 2011

7 класс