Презентация "Обработка массивов данных" 9 класс


Подписи к слайдам:
Презентация PowerPoint

Обработка массивов данных

Муниципальное общеобразовательное учреждение

Гимназия №1

Учитель информатики: Скабёлкина М.Ю.

Липецк 2011

9 класс

1. Укажите правильное расширение файлов, написанных в пакете “Excel”

  • *.doc
  • *.xls
  • *.exe

2. Какой формат числа используется для ввода даты

  • Общий
  • Время
  • Дата

3.Укажите правильный адрес ячейки:

  • А12С
  • В1256
  • 123С
  • В1А

4.В ЭТ нельзя удалить:

  • столбец
  • строка
  • имя ячейки
  • содержимое ячейки

 

5.При перемещении или копировании в ЭТ относительные ссылки:

А) не изменяются;

Б) преобразуются вне зависимости от нового положения формулы;

В) преобразуются в зависимости от нового положения формулы;

Г) преобразуются в зависимости от длины формулы.

 

6. Активная ячейка – это ячейка:

А) для записи команд;

Б) содержащая формулу, включающую в себя имя ячейки, в которой выполняется ввод данных;

В) формула в которой содержит ссылки на содержимое зависимой ячейки;

Г) в которой выполняется ввод данных.

Задача «Исследование массива температур»

Вопрос

Ответ

Что моделируем

Массив данных

Какие данные используются

Дневные и ночные температуры, зафиксированные в течении месяца

Как задаются данные

В виде таблицы

По какому критерию оцениваются данные?

По среднестатистической температуре t˚Cст, которая наблюдалась в месяце в течении многих лет

Что надо определить?

Минимальную дневную и максимальную ночную температуру и даты, когда они наблюдались, среднюю температуру за месяц и т.д.

Объект

Параметры

название

значение

Массив температур в ноябре

Дневные температуры t˚Cдн

Ночные температуры t˚Cн

Среднестатистическая температура t˚Cст

Исходные данные

Исходные данные

Исходные данные

День месяца

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

Дневная t˚C

8

14

11

6

3

0

0

-1

-2

-6

-10

-11

-7

-3

-2

Ночная t˚C

5

4

5

2

-1

-3

-2

-4

-5

-10

-14

-15

-10

-2

0

День месяца

16

17

18

19

20

21

22

23

24

25

26

27

28

29

30

Дневная t˚C

-3

-2

0

3

5

0

-5

-11

-12

-17

-20

-18

-17

-19

-17

Ночная t˚C

-5

-5

-2

0

2

-4

-7

-16

-16

-20

-25

-24

-20

-22

-20

A6

=A5+1

Подсчет следующей даты

1

D5

=(B5+C5)/2

Подсчет среднесуточной температуры

2

B36

=МАКС(B5:C34)

Максимальная дневная температура

3

C36

=МИН(C5:C34)

Минимальная ночная температура

4

D36

=СРЕДНЕЕ(D5:D34)

Средняя температура за ноябрь

5

E5

=ЕСЛИ(D5>$C$2;1;0)

Отмечаются теплые дни, когда температура была выше среднестатистической

6

E36

=СУММА(E5:E34)

Количество теплых дней

7

F5

=ЕСЛИ(B5=$B$36;A5; “-“)

Отмечается дата, когда была самая высокая дневная температура

8

G5

=ЕСЛИ(D5<8; “протапл.”; “-“)

Отмечаются дни, кода нужно протапливать помещение

9

Самостоятельная работа

Домашняя работа

Обработка массива оценок

Исследуйте самостоятельно массив оценок в дневнике за ограниченный промежуток времени. Подготовить информационную модель ее решения.

Всем спасибо за урок, до свидания!

Обработка массивов данных

Муниципальное общеобразовательное учреждение

Гимназия №1

Учитель информатики: Скабёлкина М.Ю.

Липецк 2011

9 класс