Презентация "Решение задач на использование циклических конструкций" 8 класс




Подписи к слайдам:
Слайд 1

Домашнее задание:

§ 2.4.3

С. 81- 84

РТ.

№148, 151(в)

РТ.

№155(б), 164

Проверка домашней работы

По 1 баллу

Тема урока:

Решение задач на использование циклических конструкций

Кутепова Н.В, МОАУ «СОШ №4 г.Соль- Илецка Оренбургской обл.»2016 г.

Повторить:

циклические конструкции и правила их записи.

По 1 баллу

Цели:

Научиться:

решать задачи на применение изучаемых циклов.

Проверить:

свои знания и умения.

Повторение пройденного:

Выбери верную запись алгоритма на алгоритмическом языке. Объясни. Назови исполнителя.

Использовать Робот

алг

кон

нц пока не слева свободно

закрасить

вниз

кц

нач

Использовать Робот

алг

нач

нц пока не слева свободно

закрасить

вниз

кц

кон

Использовать Робот

алг

нач

кц пока не слева свободно

закрасить

вниз

нц

кон

1 балл

Назови СКИ Робота и команды-условия

1 балл

Кутепова Н.В, МОАУ «СОШ №4 г.Соль- Илецка Оренбургской обл.»2016 г.

Вспомни виды циклических конструкций

Цикл с заданным условием продолжением работы

Цикл с заданным числом повторений

Цикл с заданным условием окончания работы

1 балл

Найди соответствие

Команды цикла с заданным числом повторений

нц пока условие

тело цикла

кц

Команды цикла с заданным условием окончания работы

нц для значение 1 до значение 2

тело цикла

кц

Команды цикла с заданным условием продолжения работы

нц

тело цикла

кц при условие

1 балл

Выполни вместе с учителем:

РТ.

№150(б)

№ 159(а)

1-2 балла

Выполни самостоятельную работу

Вариант 1

Вариант 2

РТ.

  • № 149
  • № 151(1)

РТ.

  • № 154
  • № 151 (2)

1 – 2 балла

Оценка за урок после проверки самостоятельной работы

Баллы

Оценка

1 - 2

2

3 - 4

3

5 - 6

4

7 и более

5

Кутепова Н.В, МОАУ «СОШ №4 г.Соль- Илецка Оренбургской обл.»2016 г.

Использованные материалы:

  • Л.Л. Босова, А.Ю. Босова « Информатика 8 класс». Бином. 2013.
  • Л. Л. Босова, А.Ю. Босова. Методическое пособие для 7-9 классов .ФГОС.
  • http://1.bp.blogspot.com/-Ayhh7VvGI74/UU5iYrnftuI/AAAAAAAAJJ8/epzwGPRwygo/s1600/robot_voip.png

Кутепова Н.В, МОАУ «СОШ №4 г.Соль- Илецка Оренбургской обл.»2016 г.