Презентация "Основные алгоритмические конструкции. Повторение" 9 класс


Подписи к слайдам:
ОСНОВНЫЕ АЛГОРИТМИЧЕСКИЕ КОНСТРУКЦИИ. ПОВТОРЕНИЕ

ОСНОВНЫЕ АЛГОРИТМИЧЕСКИЕ КОНСТРУКЦИИ. ПОВТОРЕНИЕ

Учитель информатики: Ризванов З.З.

Цель и задачи урока

Цель: формирование у учащихся умения решать задачи с алгоритмическими конструкциями «цикл».

Задачи:

Образовательные:

1) обобщить представления об алгоритмической конструкции «цикл»;

2) получить навыки записи циклов с заданным условием продолжения работы;

3) получить навыки выполнения циклов с заданным условием продолжения работы для различных формальных исполнителей;

4) получить навыки разработки циклов с заданным условием продолжения работы для различных формальных исполнителей с заданной системой команд.

Развивающие:

развитие логического мышления, памяти и коммуникативных навыков.

Воспитательные:

воспитание информационной культуры, внимания, аккуратности, умение слушать, аргументировать свою точку зрения.

Ключевые слова

  • Повторение
  • циклические алгоритмы
  • тело цикла
  • цикл
    • с заданным условием продолжения работы
    • с заданным условием окончания работы
    • с заданным числом повторений

Повторение

Повторение - последовательность действий, выполняемых многократно.

Алгоритмы, содержащие конструкцию повторения, называют циклическими или циклами.

Последовательность действий, многократно повторяющаяся в процессе выполнения цикла, называется телом цикла.

Типы циклов

Заданы условия

продолжения работы

Могут быть

Заданы условия

окончания работы

Задано число

повторений

Ровно 100 кирпичей

Пока есть кирпич

Пока не наступит ночь

Цикл с заданным условием продолжения работы (цикл-ПОКА, цикл с предусловием)

Запись на алгоритмическом языке:

нц пока <условие>

<тело цикла (последовательность действий)>

кц

Тело цикла

Условие

да

нет

Цикл с заданным условием продолжения работы (цикл-ПОКА, цикл с предусловием)

Выполняется цикл-ПОКА следующим образом:

  • проверяется условие (вычисляется значение логического выражения);
  • если условие удовлетворяется (ДА), то выполняется тело цикла и снова осуществляется переход к проверке условия; если же условие не удовлетворяется, то выполнение цикла заканчивается. Возможны случаи, когда тело цикла не будет выполнено ни разу.

Погрузка кирпичей

алг погрузка

нач

нц пока есть кирпичи

взять один кирпич

если кирпич целый

то положить кирпич в машину

иначе отложить кирпич в сторону

все

кц

кон

Цикл с заданным условием окончания работы (цикл-ДО, цикл с постусловием)

Запись на алгоритмическом языке:

нц

<тело_цикла (последовательность действий)>

кц при <условие>

Тело цикла

Условие

да

нет

Цикл с заданным условием окончания работы (цикл-ДО, цикл с постусловием)

Выполняется цикл-ДО следующим образом:

  • выполняется тело цикла;
  • проверяется условие (вычисляется значение логического выражения); если условие не удовлетворяется (Нет), то снова выполняется тело цикла и осуществляется переход к проверке условия; если же условие удовлетворяется, то выполнение цикла заканчивается. В любом случае тело цикла будет выполнено хоты бы один раз.

Цикл с постусловием

Пример. Алгоритм по выучиванию наизусть четверостишия.

алг четверостишие

нач

нц

прочитать четверостишие по книге 1 раз

прочитать четверостишие наизусть

кц при не сделал ошибку

кон

Цикл с заданным числом повторений (цикл-ДЛЯ, цикл с параметром)

Запись на алгоритмическом языке:

нц для i от i1 до i2 шаг R

<тело_цикла (последовательность действий)>

кц

Тело цикла

i = i1, i2

Цикл с заданным числом повторений (цикл-ДЛЯ, цикл с параметром)

Выполняется цикл-ДЛЯ следующим образом:

  • параметру цикла присваивается начальное значение;
  • параметр цикла сравнивается с конечным значением; если параметр цикла не превышает конечное значение, то выполняется тело цикла, увеличивается значение параметра цикла и снова осуществляется проверка параметра цикла; если же параметр цикла превышает конечное значение, то выполнение цикла заканчивается.
  • В отличие о двух предыдущих конструкции, цикл-ДЛЯ имеет строго фиксированное число повторений, что помогает избежать зацикливания.

Цикл с заданным числом повторений

алг переправа

нач

нц для i от 1 до 5

два мальчика переправляются на противоположный берег.

один мальчик высаживается на берег

другой мальчик плывёт обратно

солдат переправляется через реку

мальчик возвращается на исходную позицию

кц

кон

Задача № 146. Запишите на алгоритмическом языке алгоритм, представленный следующей блок-схемой

Решение

алг сбор крыжовника

нач

взять лукошко

подойти к кусту крыжовника

нц пока есть ягоды на кусте

сорвать ягоду

положить в лукошко

кц

уйти домой

кон

Самое главное

Для записи любого алгоритма достаточно трёх основных алгоритмических конструкций (структур): следования, ветвления, повторения.

Повторение - алгоритмическая конструкция, представляющая собой последовательность действий, выполняемых многократно.

Алгоритмы, содержащие конструкцию «повторение», называют циклическими или циклами.

Последовательность действий, многократно повторяющаяся в процессе выполнения цикла, называется телом цикла.

В зависимости от способа организации повторений различают три типа циклов:

цикл с заданным условием продолжения работы;

2) цикл с заданным условием окончания работы;

3) цикл с заданным числом повторений.

Домашнее задание

  • §3.4.3; вопросы и задания 23-29 к параграфу.
  • РТ № 148 стр. 88

Опорный конспект

Повторение - алгоритмическая конструкция, представляющая собой последовательность действий, выполняемых многократно.

Алгоритмы, содержащие конструкцию «повторение», называют циклическими или циклами.

Последовательность действий, многократно повторяющаяся в процессе выполнения цикла, называется телом цикла.

С заданным

условием

продолжения

работы

С заданным

условием

окончания

работы

С заданным

числом

повторений

Тип цикла

Цикл - ПОКА

Цикл - ДО

Цикл - ДЛЯ