Конспект урока "Построение заданного алгоритма из блоков"


Построение заданного алгоритма из блоков
Необходимо указать порядок записи блоков построения алгоритма
вычисления указанной величины для элементов таблицы A[1..N],
заполненной командами на АЯ.
Карточка№1.
A
нц для k
B
нц для i
C
от 1 дo N
D
от N до 1
E
если 0>a[i]
F
если 0<а[к]
G
то s:=a[k]+s
H
все кц
I
то s:=s+a[i]
J
s:=0
а) сумма положительных элементов: 1)ACFGH 2)BCFIH 3)JACFGH
4)BDFIH 5)JADEGH
б) сумма отрицательных элементов: 1)ACFGH 2)BCFIH 3)JBCFGH
4)BDFIH 5)JBCEIH.
__________________________________________________________________
Карточка №2.
A
s:=5; нц для k
B
s:=5; нц для i
C
от 1 дoN
D
от N до 1
E
если (s>a[i])
F
если (s>а[к])
G
то s:=a[k]
H
все кц
I
то s:=a[i]
J
или (k=1)
минимальное значение в таблице: 1)BDFIH 2)BCFIH 3)ACFJGH
4)ADEGH 5)ADEJGH.
__________________________________________________________________
Карточка №3.
A
нц для k
B
нц для i
C
от 1 дo N
D
от N до 1 шаг -1
E
если (0<a[k])
F
s:=s+а[i]
G
то s:=a[k] все
H
кц
I
s:=s/N
J
s:=0
среднее арифметическое значений элементов: 1)JACEGHI 2)JBDFHI
3)JBDFIH 4)BDEGHI 5)JBCFIH
Карточка №4.
A
B
нц для i
C
D
от N до 1
E
F
если (x=а[i])
G
H
все кц
I
J
p:=0;
минимальный индекс элемента, равного x: 1)ACEGH 2)JBCFIH
3)BCFIH 4)JBDFIH 5)JBDEGH
__________________________________________________________________
Карточка №5.
A
B
нц для i
C
D
от N до 1
E
F
если (x=а[i])
G
H
все кц
I
J
p:=0;
максимальный индекс элемента, равного x: 1)JACEIH 2)BCFGH
3)BDFGH 4)ADEIH 5)JADEIH
__________________________________________________________________
Карточка №6.
A
нц для k
B
нц для i
C
от 1 дo N
D
от N до 1
E
если mod(k,2)=0
F
если mod(а[i],2)=0
G
то s:=s+a[k]
H
все кц
I
то s:=s+a[i]
J
s:=0;
сумма элементов с четными индексами: 1)JBDFIH 2)BCFIH 3)BDFIH
4)JADEGH 5)ADEJGH
_______________________________________________________________
Карточка №7.
A
нц для k
B
нц для i
C
от 1 дo N
D
от N до1 шаг -1
E
если (0<a[k])
F
s:=s+а[i]
G
то s:=a[k] все
H
кц
I
s:=s/N
J
s:=0
среднее арифметическое значений элементов: 1)ACEJGH 2)JACEGH
3)JBDFIH 4)ADEGH 5)ACEGH
__________________________________________________________________
Карточка №8.
A
s:=1; нц для k
B
s:=1; нц для i
C
от 1 дoN
D
от N до 1
E
если (s<a[k])
F
если (s<а[i])
G
то s:=a[k]
H
все кц
I
то s:=a[i]
J
или (k=1)
максимальное значение в таблице: 1)ACEJGH 2)BCFIH 3)BDFIH
4)ADEGH 5)ADEJGH.