Презентация "Циклические алгоритмы" 8 класс


Подписи к слайдам:
Циклические алгоритмы

Тема урока: Циклические алгоритмы

Цель урока:

Сформировать представление о понятии «циклический алгоритм»

Алгоритмы, где необходимо повторять одни и те же действия называются повторяющимися или циклическими

Типы циклов

Заданы условия

продолжения работы

Могут быть

Заданы условия

окончания работы

Задано число

повторений

Пока есть кирпич

Ровно 100 кирпичей

Когда наступит ночь

Условие истинно?

Да

Действие 1

Действие 2

Действие n

Нет

Закончить цикл

Общий вид цикла с предусловием, записанный блок-схемой

Тело цикла

Действия, многократно повторяющиеся в процессе выполнения цикла, называют телом цикла.

нц пока <условие истинно>

<тело цикла>

кц

Общий вид цикла с предусловием, записанный алгоритмом

Есть кирпичи?

Да

Взять кирпич

Намазать кирпич цементом

Положить кирпич на стену

Нет

Цикл с заданным условием продолжения работы записанный, блок-схемой (на примере каменщика)

Закончить работу каменщика

Тело цикла

нц пока есть кирпичи

взять кирпич

намазать кирпич цементом

положить кирпич на стену

кц

Цикл с заданным условием продолжения работы, записанный алгоритмом

(на примере каменщика)

Робот в коридоре

Правее Робота расположен коридор неизвестной длины. Необходимо, чтобы Робот закрасил все клетки этого коридора.

нц пока

кц

<условие>

<действие 1>

<действие 2>

Робот в коридоре

Правее Робота расположен коридор неизвестной длины. Необходимо, чтобы Робот закрасил все клетки этого коридора.

нц пока

кц

справа свободно

вправо

закрасить

Да

x, y

(x>=1) и (y>=1)

x := x div y

y := y - 2

Нет

x, y

х

у

(х>=1) и (y>=1)

15

5

(15 >= 1) и (5 >= 1)

Да

15div5 =3

5 – 2=3

(3 >= 1) и (3 >= 1)

Да

3div3 =1

3 – 2=1

(1 >= 1) и (1 >= 1)

Да

1div1 =1

1 – 2=-1

(1 >= 1) и (-1 >= 1)

Нет

Домашнее задание:

Учебник: пункт 2.4.3. стр.81-84

Рабочая тетрадь:

№150 (б, в) № 151 (б)