Тест по информатике "Комплексный тест" 9 класс (ФГОС) скачать


Тест по информатике "Комплексный тест" 9 класс (ФГОС)

Муниципальное бюджетное общеобразовательное учреждение
«Средняя общеобразовательная школа №20»
Тест «Комплексный тест»
9 класс (ФГОС)
Автор: учитель информатики
МБОУ «СОШ №20»
Поспелова Галина Васильевна
г. Новомосковск
2018 г.
2
Пояснительная записка.
Данный дидактический материал по темам, изучаемым в курсе информатики.
Рекомендуется для учащихся 9 классов. Материал включает задания, на которые
учащиеся дают письменный ответ.
Цели:
предметные обобщение знаний по темам, изученным в курсе информатики;
метапредметные - умение самостоятельно планировать пути достижения
целей; умение соотносить свои действия с планируемыми результатами,
осуществлять контроль своей деятельности, определять способы действий в рамках
предложенных условий, корректировать свои действия в соответствии с
изменяющейся ситуацией; умение оценивать правильность выполнения учебной
задачи;
личностные - алгоритмическое мышление, необходимое для профессиональной
деятельности в современном обществе; представление о сфере возможной
профессиональной деятельности.
Решаемые учебные задачи:
1) обобщение и систематизация представлений учащихся о моделях и
моделировании, о программировании на языке Паскаль, об информационном
обществе;
2) проверка знаний учащихся по темам, изученным в курсе информатики.
3
Тест «Комплексный тест»
1. В алфавите некоторого языка всего две буквы: «А» и «Б». Все слова на этом языке
состоят из 11 букв. Каков максимально возможный словарный запас этого языка?
A. 22
B. 11
C. 2048
D. 1024
E. 44
2. В некотором текстовом редакторе имеется несколько кнопок, с помощью которых
можно получить16 различных начертаний символов (полужирный, курсив,
полужирный курсив с подчеркиванием и т.д.). Сколько кнопок используется для
этого?
A. 16
B. 3
C. 4
D. 32
E. 8
3. Буква английского алфавита (в алфавите 26 букв) может быть закодирована с
помощью двоичного кода постоянной длины. Какова минимально возможная длина
двоичного кода?
A. 26
B. 5
C. 32
D. 8
E. 256
4. Какое максимальное количество символов может содержать кодировочная
таблица, если при хранении один символ из этой таблицы занимает 10 бит памяти?
A. 800
B. 80
C. 1024
D. 512
E. 256
4
5. В процессе «цветового» преобразования растрового графического файла его
размер уменьшился в 2 раза. Сколько цветов использовалось до преобразования
изображения, если после преобразования количество цветов равно 64?
A. 4096
B. 8
C. 256
D. 2048
E. 128
6. Пусть имеется набор векторных команд:
УСТАНОВИТЬ X, Y - установить в качестве текущей позицию (X, Y).
ЛИНИЯ к X
1
, Y
1
- нарисовать линию от текущей позиции до позиции (X
1
, Y
1
), при
этом позиция X
1
, Y
1
становится текущей.
ПРЯМОУГОЛЬНИК X
1
, Y
1
, X
2
, Y
2
- нарисовать прямоугольник, у которого (X
1
, Y
1
)
- координаты левого верхнего угла, (X
2
, Y
2
) - координаты правого нижнего угла.
ЦВЕТ РИСОВАНИЯ цвет - установить текущий цвет рисования.
ЦВЕТ ЗАКРАСКИ цвет - установить цвет закраски.
ЗАКРАСИТЬ X, Y - закрасить произвольную замкнутую фигуру, где (X, Y) —
координаты любой точки внутри этой фигуры.
Что будет нарисовано в результате выполнения следующих векторных команд:
Цвет рисования Коричневый;
Установить 0,40; Линия к 100,40; Линия к 100,60;
Линия к 20,60; Линия к 0,40;
Цвет закраски Коричневый;
Закрасить 30,50; Установить 60,40;
Цвет рисования Черный;
Линия к 60,0; Цвет рисования Желтый;
Прямоугольник 60,0,80,15;
Цвет закраски Желтый; Закрасить 65,10?
A. Лодка черного цвета высотой 20 с флагом желтого цвета; размеры флага: высота
15, а ширина 20
B. Лодка коричневого цвета высотой 40 с флагом черного цвета; размеры флага:
высота 15, а ширина 20
C. Лодка коричневого цвета высотой 20 с флагом желтого цвета; размеры флага:
высота 15, а ширина 20
D. Лодка коричневого цвета высотой 20 с флагом черного цвета; размеры флага:
высота 15 и ширина 15
E. Лодка коричневого цвета высотой 30 с флагом желтого цвета; размеры флага:
высота 15 и ширина 15
5
7. Для победителя школьной олимпиады по информатике подготовили подарок,
состоящий из одного лазерного диска, мышки и коврика. Сколькими способами
можно составить такой подарок, если в распоряжении организаторов имеются 2
лазерных диска с разным программным обеспечением, 3 мышки разных моделей и 2
коврика разного цвета?
A. 7
B. 12
C. 6
D. 1
E. 3
8. Если Вику, Соню, Борю, Дениса и Аллу упорядочить по возрасту, то разница
между соседями составит 1 год. Вике 10 лет. Вика моложе Сони, но старше Аллы.
Разница в возрасте между Борисом и Аллой больше 1 года. Разница в возрасте
между Денисом и Аллой, Денисом и Викой,
Денисом и Борисом тоже больше 1 года. Сколько лет каждому?
A. Алле - 9 лет; Борису - 12 лет; Денису - 8 лет; Соне - 11 лет
B. Алле - 9 лет; Борису - 11 лет; Денису - 13 лет; Соне - 12 лет
C. Алле - 8 лет; Борису - 9 лет; Денису - 12 лет; Соне - 11 лет
D. Алле - 9 лет; Борису - 8 лет; Денис - 12 лет; Соне - 11 лет
E. Алле - 9 лет; Борису - 12 лет; Денису - 11 лет; Соне - 13 лет
9. Год является високосным, если его порядковый номер кратен 4. Годы, номера
которых кратны100, являются високосными только при условии, что их номера
кратны 400. Выбрать логическое выражение, принимающее значение ИСТИНА,
если год с порядковым номером N является високосным. Функция XMOD Y
вычисляет остаток от деления двух целых чисел X и Y.
A. (N MOD 4 = 0) OR (N MOD 400 = 0)
B. (N MOD 4 = 0) OR (N MOD 100 = 0) AND (N MOD 400 = 0)
C. (N MOD 4 = 0) AND (N MOD 100 = 0) OR (N MOD 400 = 0)
D. (N MOD 4 = 0) AND (N MOD 100 <> 0) OR (N MOD 400 = 0)
E. (N MOD 4 = 0) AND (N MOD 100 <> 0) AND (N MOD 400 = 0)
10. При истинности какого логического выражения последовательность значений
переменных A, B и C не является упорядоченной по возрастанию?
A. (A< B) AND (NOT(B ≥ C))
B. NOT((A< B) AND (B< C))
C. NOT((A> B) OR (B> C))
D. (A ≤ B) AND (NOT(B> C))
E. (A ≤ B) AND (B ≤ C)
6
11. В клетку B1 электронной таблицы занесена формула:
=ЕСЛИ(И(A1>0;A1<10);1;0).
Какие формулы дают тот же самый результат?
1. =ЕСЛИ(A1>0;1;ЕСЛИ(A1<10;1;0))
2. =ЕСЛИ(A1>0;ЕСЛИ(A1<10;1;0);0)
3. =ЕСЛИ(НЕ(ИЛИ(A1<=0;A1>=10));1;0)
A. Все три формулы
B. 1 и3
C. 2 и3
D. 1
E. Таких формул нет
12. Разговоры по телефону оплачиваются следующим образом. Если абонент
использовал не более 300 минут (норма), то оплата одной минуты разговора идет по
тарифу 20 копеек за минуту, оплата каждой минуты сверх нормы идет по тарифу 25
копеек за минуту. Выбрать формулу, позволяющую вычислить денежную сумму
рублях), подлежащую к оплате, если количество минут занесено в клетку С4
электронной таблицы.
A. =ЕСЛИ(C4<=300;C4*0,2;C4*0,25)
B. =ЕСЛИ(C4<=300;C4*0,2;300*0,2+C4*0,25)
C. =ЕСЛИ(C4<=300;C4*0,2;(C4–300)*0,25)
D. =ЕСЛИ(C4<=300;C4*0,2;300*0,2+(300–C4)*0,25)
E. =ЕСЛИ(C4<=300;C4*0,2;300*0,2+(C4–300)*0,25)
13. Указать максимальное трехразрядное число, представимое в системе счисления с
основанием 8. Ответ дать в десятичной системе счисления.
A. 511
B. 777
C. 512
D. 888
E. 999
14. Двоичное число после перевода в систему счисления с основанием 32 содержит
6 цифр. Сколько цифр будет содержать это число после перевода в систему
счисления с основанием 8?
A. 18
B. 8
C. 5
D. 6
E. 10
7
15. Указать наибольшее из чисел
A. 113
4
B. 113
8
C. 113
5
D. 113
11
E. 113
13
16. Представители племени оперируют целыми положительными числами и умеют
считать только до 77. Для проведения расчетов в племени применяется калькулятор.
Указать минимальную длину ячейки памяти в битах, необходимую для
представления чисел.
A. 100
B. 6
C. 7
D. 8
E. 101
База знаний «Распорядок дня» задана следующими фактами:
занятие (0,7,сон).занятие(7,8,завтрак).занятие(8,13,школа).
занятие(13,14,обед).занятие(14,16,прогулка).занятие16,19,уроки).
занятие(19,20,ужин).занятие(20,23,отдых).
17. Сформулировать вопрос: «Чем занимается ребенок между14 и 19 часами?»
A. занятие(14,19,X).
B. занятие(A,19,X),A>=14.
C. занятие(A,B,X),A>=14,B<=19.
D. занятие(A,B,X),A<=14,B>=19.
E. занятие(A,B,X),A>=14;B<=19.
18. Сформулировать вопрос, позволяющий выяснить время, когда ребенок посещает
школу или делает уроки.
A. занятие(X,Y,школа),занятие(X,Y,уроки).
B. занятие(X,Y,школа);занятие(X,Y,уроки).
C. занятие(X,Y,Z);Z=школа;Z=уроки.
D. занятие(X,Y,Z),Z=школа,Z=уроки.
E. занятие(X,Y,Z),Z=школа;Z=уроки.
8
19. Каким будет ответ на цель: занятие(7,8,завтрак);занятие(Z,Wбед)?
A. Z=14 W=13
B. Нет решения
C. Z=13 W=14
D. “Да”
E. “Да” иZ=13 W=14
База данных «Расписание уроков» задана таблицей. Записи в таблице
пронумерованы.
20. Определить первичный ключ этой таблицы.
A. Номер урока
B. День недели+ Номер урока
C. День недели+ Название
D. День недели+ Номер урока+ Название
E. День недели+ Номер урока+ Учитель
21. Выберите условие запроса, позволяющего получить список учителей, у которых
в четверг время хотя бы одного из уроков попадает в период между 9.30 и 11.00
часами.
A. День= «Четверг» AND Начало>=9.30 AND Конец<=11.00
B. (Начало>=9.30 OR Конец<=11.00) AND День= «Четверг»
C. (Начало>=9.30 AND Начало<=11.00 OR Конец>=9.30 AND Конец<=11.00)
AND День= «Четверг»
D. Начало>=9.30 AND Начало<=11.00 OR Конец>=9.30 AND Конец<=11.00
AND День= «Четверг»
E. (Начало>=9.30 AND Конец<=11.00 OR Конец>=9.30) AND День= «Четверг»
22. После сортировки по двум ключам в порядке возрастания записи расположены в
следующем порядке: 1; 7; 2; 3; 4; 5; 8; 9; 6. Определить все возможные ключи
сортировок, позволяющие получить такой порядок следования записей.
1) Номер урока+ Учитель;
2) Учитель+ Номер урока;
3) Начало+ Учитель;
4) Конец+ Учитель.
A. 1); 2); 3); 4)
B. 2)
C. 2); 3); 4)
D. 1); 3); 4)
E. 3); 4)
9
23. Известны имя почтового сервера (mserver), находящегося в России, и имя
почтового ящика (Paul). Определить электронный адрес.
A. mserver@Paul.ru
B. mserver@Paul.Russia
C. mserver.Paul@ru
D. Paul.mserver@ru
E. Paul@mserver.ru
24. В универсальном указателе ресурсов(URL-адрес)
http:// www.eas.asu.edu/public/pefdhome указать имя сервера.
A. public
B. pefdhome
C. www.eas.asu.edu
D. asu.edu
E. public/pefdhome
25. Программа, устанавливаемая на компьютере пользователя и используемая для
навигации по сети Интернет, - это
A. Поисковый сервер
B. Почтовый агент
C. Сетевой робот
D. Браузер
E. Rambler
26. Модем, передающий информацию со скоростью 28 800 бит/с, может передать 3
страницы текста, на каждой из которых 40 строк по 60 символов в строке, в
течение…
A. 0,125 с
B. 1 с
С. 2 с
D. 4 с
E. 8 с
10
Имеется исполнитель Кузнечик, который живет на числовой оси. Система
команд Кузнечика:
Вперед N - прыгает по числовой оси вперед на N единиц;
Назад N - прыгает по числовой оси назад на N единиц.
27. Кузнечик выполнил программу из 50 команд, в которой команд Назад 2 на 10
больше, чем команд Вперед 3 (других команд нет). На сколько единиц и в какую
сторону сместился Кузнечик?
A. Такой программы не может быть
B. На 20 единиц вперед
C. На 30 единиц вперед
D. Вернулся в исходное положение
E. На 30 единиц назад
28. В какие из точек: 480; 115; 555; 160; 220 - может допрыгать Кузнечик из
начального положения в точке 0, если он умеет выполнять только команды
Вперед 15 и Назад 6?
A. 115 и 555
B. 480 и 555
C. 160; 220 и 480
D. Во все указанные точки
E. Ни в одну из указанных точек
29. Кузнечик выполнил некоторую программу из 13 команд и оказался на 3 единицы
правее того места, с которого он начал. Сколько в программе команд Вперед 5 и
Назад 3, если других команд нет?
A. Такой программы не может быть
B. 8 и 5
C. 4 и 9
D. 9 и 4
E. 5 и 8
30. Стартовав из точки 0 и выполнив некоторую программу, Кузнечик побывал
последовательно в точках 0; 3; 1; 4; 2; 0; –2. В каких точках побывает Кузнечик,
выполняя эту же программу, если стартует из точки (5)?
A. 5; 8; 6; 9; 7; 5; 3
B. 5; 8; 6; 9; 7; 5; 3
C. 5; 2; 4; 1; 3; 5; 7
D. 5; 2; 4; 1; 3; 5; 3
E. 6; 3; 5; 2; 4; 6; 8
11
Источники информации:
1. Босова Л. Л. Информатика : учебник для 7 класса / Л.Л. Босова, А.Ю. Босова -
Москва : БИНОМ. Лаборатория знаний , 2015 - 224 с.
2. Босова Л. Л. Информатика : рабочая тетрадь для 7 класса / Л.Л. Босова, А.Ю.
Босова - Москва : БИНОМ. Лаборатория знаний , 2015 - 160 с.
3. Босова Л. Л. Информатика : учебник для 8 класса / Л.Л. Босова, А.Ю. Босова -
Москва : БИНОМ. Лаборатория знаний , 2015 - 160 с.
4. Босова Л. Л. Информатика : рабочая тетрадь для 8 класса / Л.Л. Босова, А.Ю.
Босова - Москва : БИНОМ. Лаборатория знаний , 2015 - 160 с.
5. Босова Л. Л. Информатика : учебник для 9 класса / Л.Л. Босова, А.Ю. Босова -
Москва : БИНОМ. Лаборатория знаний , 2015 - 184 с.
6. Босова Л. Л. Информатика : рабочая тетрадь для 9 класса / Л.Л. Босова, А.Ю.
Босова - Москва : БИНОМ. Лаборатория знаний , 2015 - 176 с.
7. Русаков С.В. Тестовые задания по базовому курсу информатики/ С.В. Русаков,
Л.В. Шестакова. М. : Чистые пруды, 2006. – 32 с.
12
Ключ к тесту
1
2
3
4
5
6
7
9
10
11
12
13
14
15
C
C
B
C
A
C
B
D
B
C
E
A
E
E
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
C
C
B
D
E
C
D
E
C
D
C
D
B
A
C